
AI-Powered CVE Analysis for WordPress Plugins
We use AI to automate the differential analysis between vulnerable and patched plugin versions to understand and interpret the security issues. What we share here is research-grade proof of concept demonstrations that are then fed back into our endpoint firewall service.
WordPress Proof of Concepts
AI-assisted vulnerability analysis with PoC demonstration
March 23, 2026
CVE-2025-14982: Booking Calendar <= 10.14.11 Missing Authorization to Sensitive Information Exposure PoC, Patch Analysis & Rule
CVE-2025-14982 affects the Booking Calendar plugin (up to version 10.14.11) with a medium severity (CVSS 4.3) vulnerability. Authenticated users can access sensitive booking data; update to version 10.14.12 to mitigate risks.
March 23, 2026
CVE-2025-14384: All in One SEO – Powerful SEO Plugin to Boost SEO Rankings & Increase Traffic <= 4.9.2 Missing Authorization to Authenticated (Contributor+) AI Access Token and Credit Disclosure PoC, Patch Analysis & Rule
CVE-2025-14384 affects the All In One SEO Pack plugin (up to version 4.9.2) with a CVSS score of 4.3. It allows authenticated attackers to access sensitive data. Upgrade to version 4.9.3 to mitigate this vulnerability.
March 23, 2026
CVE-2025-68003: Shown Connector <= 1.2.10 Missing Authorization to Unauthenticated Settings Update PoC, Patch Analysis & Rule
CVE-2025-68003 affects the Shown Connector plugin for WordPress (versions
March 23, 2026
CVE-2025-15370: Shield Security <= 21.0.9 Authenticated (Subscriber+) Insecure Direct Object Reference to Disable Google Authenticator PoC, Patch Analysis & Rule
CVE-2025-15370 affects Wp Simple Firewall plugin versions up to 21.0.9 with a medium severity (CVSS 4.3). Authenticated attackers can disable Google Authenticator for users. Update to version 21.0.10 to mitigate this risk.
March 23, 2026
CVE-2025-13062: Supreme Modules Lite <= 2.5.62 Authenticated (Author+) Arbitrary File Upload via JSON Upload Bypass PoC, Patch Analysis & Rule
CVE-2025-13062 affects the Supreme Modules For Divi plugin (up to v2.5.62) with a high severity CVSS score of 8.8. Authenticated users can exploit a file upload vulnerability. Update to v2.5.63 to mitigate risks.
March 23, 2026
CVE-2026-24599: NextMove Lite <= 2.23.0 Unauthenticated Insecure Direct Object Reference PoC, Patch Analysis & Rule
CVE-2026-24599 affects Woo Thank You Page Nextmove Lite plugin versions up to 2.23.0, allowing remote code execution due to insecure direct object reference. Update to version 2.24.0 to mitigate this medium severity vulnerability.
March 23, 2026
CVE-2025-12641: Awesome Support – WordPress HelpDesk & Support Plugin <= 6.3.6 Missing Authorization to Unauthenticated Role Demotion PoC, Patch Analysis & Rule
CVE-2025-12641 affects Awesome Support plugin versions up to 6.3.6, allowing unauthenticated users to demote admins due to an authentication bypass. Upgrade to 6.3.7 to mitigate this medium severity issue.
March 23, 2026
CVE-2026-0913: User Submitted Posts <= 20260110 Authenticated (Contributor+) Stored Cross-Site Scripting via 'usp_access' Shortcode PoC, Patch Analysis & Rule
CVE-2026-0913 affects the User Submitted Posts plugin for WordPress, with a CVSS score of 6.4. Authenticated attackers can exploit this cross-site scripting vulnerability. Update to version 20260113 to mitigate risks.
March 23, 2026
CVE-2025-13859: AffiliateX 1.0.0 1.3.9.3 Authenticated (Subscriber+) Missing Authorization to Stored Cross-Site Scripting via save_customization_settings PoC, Patch Analysis & Rule
CVE-2025-13859 affects the AffiliateX plugin for WordPress (versions 1.0.0 to 1.3.9.3) with a medium severity CVSS score of 6.4. Update to version 1.4.0 to mitigate cross-site scripting risks from authenticated attackers.
March 23, 2026
CVE-2025-68015: Event Tickets with Ticket Scanner <= 2.8.5 Unauthenticated Remote Code Execution PoC, Patch Analysis & Rule
CVE-2025-68015 affects the Event Tickets With Ticket Scanner plugin (up to v2.8.5) with a critical CVSS score of 9.8. Patch to v2.8.6 to mitigate remote code execution risks.
March 23, 2026
CVE-2026-22335: WooCommerce Frontend Manager – Ultimate < 6.7.7 Authenticated (Subscriber+) SQL Injection PoC, Patch Analysis & Rule
CVE-2026-22335 affects the WooCommerce Frontend Manager – Ultimate plugin (up to v6.7.7) with a medium severity (CVSS 6.5) SQL injection vulnerability. Authenticated attackers can exploit this to access sensitive data; patch immediately.
March 23, 2026
CVE-2026-1003: GetGenie – AI Content Writer with Keyword Research & SEO Tracking Tools <= 4.3.0 Missing Authorization to Authenticated (Author+) Arbitrary Post Deletion PoC, Patch Analysis & Rule
CVE-2026-1003 affects the Getgenie plugin (up to v4.3.0), allowing authenticated users to delete posts due to an authentication bypass. Upgrade to v4.3.1 to mitigate this medium severity vulnerability.
March 23, 2026
CVE-2025-68034: CleverReach® WP <= 1.5.21 Unauthenticated SQL Injection PoC, Patch Analysis & Rule
CVE-2025-68034 reveals a high-severity SQL injection vulnerability in the CleverReach WP plugin (up to 1.5.21). Update to 1.5.22 to mitigate risks of unauthorized data access.
March 23, 2026
CVE-2026-24595: Zoho CRM Lead Magnet <= 1.8.1.7 Missing Authorization PoC, Patch Analysis & Rule
CVE-2026-24595 affects the Zoho CRM Forms plugin (up to 1.8.1.7) with a medium severity (CVSS 4.3) flaw allowing unauthorized actions by authenticated users. Update to the patched version to mitigate this risk.
March 23, 2026
CVE-2026-24596: Related Posts Thumbnails Plugin for WordPress <= 4.3.2 Cross-Site Request Forgery PoC, Patch Analysis & Rule
CVE-2026-24596 affects the Related Posts Thumbnails plugin for WordPress versions up to 4.3.2, with a CVSS score of 4.3. Users should upgrade to 4.3.3 to mitigate the Cross-Site Request Forgery risk.
March 23, 2026
CVE-2025-68896: WDV One Page Docs <= 1.2.4 Missing Authorization PoC, Patch Analysis & Rule
CVE-2025-68896 affects the WDV One Page Docs plugin for WordPress (up to 1.2.4) with a medium severity (CVSS 5.3) vulnerability. Unauthenticated users can exploit this flaw, so ensure you update to the patched version.
March 23, 2026
CVE-2025-68884: Simple Redirect <= 1.1 Reflected Cross-Site Scripting PoC, Patch Analysis & Rule
CVE-2025-68884 affects the Wp Simple Redirect plugin (up to version 1.1) with a medium severity CVSS score of 6.1. Unauthenticated attackers can exploit this reflected XSS vulnerability, highlighting the need for immediate patching.
March 23, 2026
CVE-2026-24594: Livemesh Addons for WPBakery Page Builder <= 3.9.4 Authenticated (Editor+) Stored Cross-Site Scripting PoC, Patch Analysis & Rule
CVE-2026-24594 affects the Addons For Visual Composer plugin (up to v3.9.4) with a medium severity (CVSS 4.4) cross-site scripting vulnerability. Ensure proper input sanitization and consider patching to mitigate risks.
March 23, 2026
CVE-2025-68864: Infility Global <= 2.14.49 Unauthenticated Stored Cross-Site Scripting PoC, Patch Analysis & Rule
CVE-2025-68864 affects the Infility Global plugin (up to version 2.14.49) with a CVSS score of 7.2. This high-severity XSS vulnerability allows attackers to inject scripts, impacting user security. Update to the patched version.
March 23, 2026
CVE-2025-68007: Event Espresso 4 Decaf <= 5.0.37.decaf Missing Authorization to Unauthenticated Settings Change PoC, Patch Analysis & Rule
CVE-2025-68007 affects the Event Espresso Decaf plugin (up to 5.0.37.decaf) with a CVSS score of 6.5. Unauthenticated attackers can exploit this medium-severity vulnerability for unauthorized actions. Update to 5.0.54.decaf to mitigate.
How Atomic Edge Works
Simple Setup. Powerful Security.
Atomic Edge acts as a security layer between your website & the internet — inspecting, filtering, and blocking malicious traffic before it ever reaches
your application.
